Kişisel Birşeyler

OpenCart mysql_connect() Sorunu Çözümü

deprecated: mysql_connect()

Opencart 1.5x sürümlerinde Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future benzeri bir hata alıyorsanız, çözüm için aşağıdaki adımları uygulayın.

Örnek Hatalar:

Parse error: syntax error, unexpected ‘else’ (T_ELSE), expecting function (T_FUNCTION) in /home/SITEADI/public_html/SITEDIZINI/system/database/mysqli.php on line 54

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/SITEADI/public_html/SITEDIZINI/system/database/mysql.php on line 6

Neden Bu Hatalarla Karşılaşıyorsunuz:

Opencart 1.5x sürümlerinde sunucu php sürümü 5.5 ve üzeri seçildiğinde bazı sistemler aşağıdaki hataları vermektedir.

Opencart mysql_connect() Sorunu Çözüm 1

  • Sunucu PHP sürümünüzü 5.4 olarak ayarlayın.

Opencart mysql_connect() Sorunu Çözüm 2

  • FTP ile sunucunuza bağlanın.
  • ana dizindeki config.php ve admin klasörü içinde bulunan config.php dosyalarını açın.
  • define(‘DB_DRIVER’, ‘mysql’); satırlarını bulup, aşağıdaki ile değiştirin.
  • define(‘DB_DRIVER’, ‘mysqliz’);
  • Aşağıdaki system.zip dosyasını indirip sunucunuza gönderin.
  • Sorun düzelecektir.

system.zip dosyasını indirmek için tıklayın.



Bu yazıyı değerlendirin.
2     5/5

Yorumlar

  Abone Ol  
Bildir